Blue Flower

Monday, 06 July 2015 00:32

sa-learn error - bayes db version 2 is not able to be used, aborting

Written by
Rate this item
(0 votes)

Stop spamassassin/spamd (ie: you don't want it to be running during the upgrade).

Run "sa-learn --rebuild", this will sync your journal. if you skip this step, any data from the journal will be lost when the DB is upgraded.

Run "sa-learn --sync", which will cause the db format to be upgraded. If you want to see what is going on, you can add the "-D" option.

Test the new database by running some sample mails through SpamAssassin, and/or at least running "sa-learn --dump" to make sure the data looks valid.

Start running spamassassin/spamd again.

Read 1621 times Last modified on Monday, 06 July 2015 00:50

Leave a comment

Make sure you enter all the required information, indicated by an asterisk (*). HTML code is not allowed.